[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Generating config for new RAID array

From: Kjetil Kjernsmo
Subject: Re: Generating config for new RAID array
Date: Tue, 29 Aug 2017 14:43:04 +0200
User-agent: KMail/5.2.3 (Linux/4.9.0-3-amd64; KDE/5.28.0; x86_64; ; )

Hi all!

First, thanks for the replies! I got distracted over the weekend, but 
managed to get it working now. 

On Sunday, 27 August 2017 11:56:41 CEST Pascal Hambourg wrote:
> Did you run grub-mkconfig from the system installed on the RAID array or
> from another system ?

I ran it on the same system, but when the system was running from a 
different partition.

However, the key to solve the problem was when I realized that the UUID 
that was searched for by the search command was not just the FS UUID 
without hyphens.

This dawned on me when I tried to chroot and got an error from grub-probe. 
Then, I started to use grub-probe with various targets. 

> I would suggest to edit grub.cfg manually for the first boot on the RAID
> array, then you can check that grub-mkconfig generates proper menu
> entries.

Indeed, and when I got the UUIDs right, that's what worked in the end. :-) 
Now, I let update-grub call grub-mkconfig. It finds both the MD RAID and the 
old disk.

> Also, check that the initramfs is setup to start at least required RAID
> arrays (root, /usr). See /etc/default/mdadm.

Right, that's set to "all", so we should be good.

> > Allthough I don't see an menuentry generated for the new array, I see
> > the domdadm getting onto the boot line, so at least the
> > /etc/default/grub is correct.
> What's "domdadm" ? 

I got that from

> AFAIK, it is not used to boot from RAID with an initramfs generated by
> the default initramfs generator (initramfs-tools).

Right... Yeah, it works without... What is domdadm intended for?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]