[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help w/Error #14 in grub legacy (version 0.97)

From: ejm
Subject: Help w/Error #14 in grub legacy (version 0.97)
Date: Sun, 16 Apr 2017 06:29:40 -0700 (GMT-07:00)

Hi all,

I am getting Error #14 from grub version 0.97 when trying to boot for the first 
time into a newly installed partition with Scientific Linux 6.7 and need help 
resolving the error.

The setup:

MacPro with 2 HDs

HD #1:   ESP partition has rEFInd installed and running
         2nd partition: Mac OSX 10.7.5 (lion) installed

HD #2:  1st partition: Centos 6.8           (uses grub version 0.97)     
filesystem = ext4
        2nd partition: Debian 8.7           (uses grub 2.0.2 beta).      
filesystem = ext4
        3rd partition: Scientific Linux 6.7 (uses grub version 0.97).    
filesystem = ext4

The grub.conf in the CentOS partition has the following entries:

title CentOS 6.8 (2.6.32-696.el6.x86_64)
root (hd0,0)
kernel /boot/vmlimuz-2.6.32-696.el6.x86_64 ro 
root=UUID=531c3b86-dc7e-4d14-9505-6df970dc8495 rd_NO_LUKS rd_NO_LVM 
LANG=en_US.UTF-8 rd_no_MD SYSFONT=latarcyrheb=sun16 crashkernel=128M 
initrd /boot/initramfs-2.6.32-696.el6.x86_64.img

title Debian 8.7
root (hd0,1)
chainloader +1

title Scientific Linux 6.7 (Carbon)
kernel /boot/vmlinuz-2.6.32-573.el6.x86_64 ro 
initrd /boot/initramfs-2.6.32-573.el6.x86_64.img
chainloader +1

I can boot fine into the Mac OSX from rEFInd.

When I boot from rEFInd into the CentOS partition I get the Grub version 0.97 
menu list with the 3 OSs listed above.

I can then boot fine into CentOS 6.8 or Debian 8.7 just fine.

I just added Scientific Linux 6.7 (SL) from a downloaded ISO image to the 3rd 
SL installed fine. The installation itself was done using a PC (AMD64) running 
Windows 7 and the HD connected via USB and a mobile SATA dock.

But using the above grub config for SL I get Error #14.

If I comment-out the kernel and initrd lines in the SL entry I get Error #13.

I confirmed that the kernel and the initramfs files both are in /boot in SL.

I also checked the UUID for the 3rd partition with blkid and that is correct 

If I replace the kernel line for SL with the same one in the SL parititon I 
still get Error #14. The only difference with the full CentOS and SL kernel 
entries are the UUIDs of the partition and the minor version # (696 vs 573).

I haven't seen anything specific to Error #14 in the blog entries I've seen.

Everything I've tried results in either Error #14 or 13.

I do think the SL partititon will boot if given the correct grub conf to start 

Any tips or ideas would be greatly appreciated!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]