[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Not able to netboot UEFI arm64 system with a GRUB.

From: jorgesanjuan
Subject: Not able to netboot UEFI arm64 system with a GRUB.
Date: Fri, 24 Jun 2016 12:05:11 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.1.1


I am trying to boot a UEFI ARM64 system on the net. My tftp server is an amd64 machine and the UEFI client is a arm64 machine. When I net-boot the arm64 system I can only see the GRUB's rescue shell and if I press 'ls' I can only see the (hd0) device.

However, I've been trying to run the linux command on the GRUB's shell as follows:

grub> set net_default_server=
grub> set root=(tftp,
grub> linux /fedora23Aarch64/vmlinuz
error: timeout: could not resolve hardware address.

# The tftp server root is in /var/lib/tftpboot and I have vmlinuz there for now.

When I do this, however, I can see some ARP requests/ replies on the server side, but the tftp connection never starts.

On the other hand, I've been using available arm64 GRUBs on different linux distros:

- Ubuntu:
- Fedora: (Grubaa64.efi)

I then tried to create my own grub (maybe those grubs where not allowing tftp devices) to control all the modules I put on it but I couldn't make my own GRUB following this (3.2 chapter):

The error I got when doing make after ./autoconf and ./configure  is:

In file included from term/efi/serial.c:29:0:
../include/grub/serial.h:25:25: fatal error: grub/cpu/io.h: No such file or directory
 #include <grub/cpu/io.h>

(See attached file for more details).

Hopefully I can have this solved.

Thank you,

Attachment: grub_log
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]