[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 "unknown filesystem"

From: Andrei Borzenkov
Subject: Re: Grub2 "unknown filesystem"
Date: Mon, 30 Nov 2015 20:01:41 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.3.0

30.11.2015 18:42, Avi Deitcher пишет:
> I am struggling with a multiple OS install of grub2. Currently I have just
> CentOS 7 (/boot sda2) and CentOS 6.6 (/boot sda9) installed.
> system is structured BIOS/GPT.
> grub2 loads, menu comes up, but I cannot boot into 6.6, only into 7. The
> error message is "unknown filesystem".
> If I drop into grub2 command-prompt, "ls" lists all of the partitions
> without a problem. If I try to "ls (hd0,2)" it shows the partition info
> (happens to be xfs), and "ls (hd0,2)/" shows files. If I try to "ls
> (hd0,9)", it shows "unknown filesystem".
> Once booted into CentOS 7, I am able to cleanly see and mount sda9. I tried
> rebuilding the sda9 /boot partition as ext2, ext4 and xfs, then
> grub2-mkconfig and grub2-install, all with the same result.
> I posted details on a stackoverflow question here

What you *can* see on this disk? It is possible that we face BIOS issue
with access too far from the beginning of disk. Which is the last
partition you can see?

Try loading lvm module, which volumes become visible?

Also retest with current master would be good.

> The BIOS boot and GPT must be fine, or grub2 wouldn't load. The filesystem
> drivers must be fine, or it wouldn't be able to load (hd0,2). The sda9
> should be fine, or it wouldn't mount once in CentOS.
> grub install:
> # rpm -qa | grep grub
> grub2-2.02-
> grubby-8.28-11.el7.x86_64
> grub2-tools-2.02-
> What could possibly be wrong?
> _______________________________________________
> Help-grub mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]