[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 chainloader bootmgfw.efi not working

From: Vyacheslav Gonakhchyan
Subject: Re: Grub2 chainloader bootmgfw.efi not working
Date: Mon, 14 Sep 2015 16:36:26 +0400

My Grub2 is EFI. I use grub-install --target=x86_64-efi --efi-directory=/boot/efi /dev/sda which calls efibootmgr to load grubx64.efi into UEFI BIOS.

>echo $grub_cpu $grub_platform
Sorry, can only check it later. I'm guessing x86_64, efi-64...

On Mon, Sep 14, 2015 at 4:11 PM, Andrei Borzenkov <address@hidden> wrote:
On Mon, Sep 14, 2015 at 2:36 PM, Vyacheslav Gonakhchyan
<address@hidden> wrote:
> Hi, everyone!
> I have dual boot config Archlinux/Windows7 and latest packages. I am booted
> into grub rescue mode. Or use command line. I want to tell Grub2 to load
> Windows Boot Loader bootmgfw.efi. Basically grub2 refuses to do it with
> error "invalid root device".
> Steps to reproduce:
>> set root=(hd1,gpt7)
>> chainloader /EFI/Microsoft/Boot/bootmgfw.efi
> Screen is flashing with "invalid root device".

Is your grub BIOS or EFI? What are values for grub_cpu and grub_platform?

echo $grub_cpu $grub_platform

> So grub2 finds bootmgfw.efi but cannot give it control. I tried every other
> hd1,gpt combination to no avail.  I also tried setting root to one device
> and loading bootmgfw.efi from another device(hd1,gpt7).
> It's strange because I can load this file from shell (shellx64.efi) within
> UEFI BIOS without error. Any advice is appreciated.
> Regards,
> Viacheslav
> _______________________________________________
> Help-grub mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]