[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub2 chainloader bootmgfw.efi not working

From: Vyacheslav Gonakhchyan
Subject: Grub2 chainloader bootmgfw.efi not working
Date: Mon, 14 Sep 2015 15:36:42 +0400

Hi, everyone!

I have dual boot config Archlinux/Windows7 and latest packages. I am booted into grub rescue mode. Or use command line. I want to tell Grub2 to load Windows Boot Loader bootmgfw.efi. Basically grub2 refuses to do it with error "invalid root device".

Steps to reproduce:
> set root=(hd1,gpt7)
> chainloader /EFI/Microsoft/Boot/bootmgfw.efi
Screen is flashing with "invalid root device".

So grub2 finds bootmgfw.efi but cannot give it control. I tried every other hd1,gpt combination to no avail.  I also tried setting root to one device and loading bootmgfw.efi from another device(hd1,gpt7).
It's strange because I can load this file from shell (shellx64.efi) within UEFI BIOS without error. Any advice is appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]