[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: can't get a correct resolution[halt-solved]

From: François Patte
Subject: Re: can't get a correct resolution[halt-solved]
Date: Fri, 03 Jul 2015 15:10:19 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0

Hash: SHA1

Le 02/07/2015 05:16, Andrei Borzenkov a écrit :
> В Wed, 01 Jul 2015 23:41:58 +0200 François Patte
> <address@hidden> пишет:
>>>>> If your kernel is using KMS drivers legacy VESA resolution
>>>>> is effectively ignored. Try passing video=1280x1024 on
>>>>> kernel command line.
>>>> Thank you for answering. I tried this but nothing
>>>> changed....
>>> Out of curiosity - what if you boot with nomodeset parameter 
>>> additionally? This should disable KMS completely.
>> No change....
>> I use nvidia driver, is this the source of the problem? If yes,
>> how to solve it? When I boot the debian (which also use the
>> nvidia driver) the resolution is correct...
> Sorry, no idea. But I do not see how GRUB can do anything here.
> After kernel is loaded it is up to kernel to set resolution. Did
> you try asking on Fedora forums?

I did, but no answer was given except to contact help-grub list....

I found a culprit: the command linux16 in the /boot/grub2/grub.cfg. If
I change this command to linux, I can get the correct resolution
during the boot.

3 questions arise:

1- The first line of the boot message begins by "failed" in red color,
but I cannot see what has failed because the display is too fast and I
cannot stop it using the pause keys of the keyboard... How to slow
down the messages? (my system is on SSD, so the boot takes less than

2- Changing linux16 to Linux seems to not affect the boot. Am I right?

3- How to get this change (linux16 to linux) resists to updates?

Thank you.

- -- 
François Patte
UFR de mathématiques et informatique
Laboratoire CNRS MAP5, UMR 8145
Université Paris Descartes
45, rue des Saints Pères
F-75270 Paris Cedex 06
Tél. +33 (0)1 8394 5849
Version: GnuPG v2


Attachment: 0xD855D895.asc
Description: application/pgp-keys

reply via email to

[Prev in Thread] Current Thread [Next in Thread]