[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: about an grub 2.00 installation error, bug, defect

From: Jordan Uggla
Subject: Re: about an grub 2.00 installation error, bug, defect
Date: Tue, 28 Oct 2014 21:36:22 -0700

On Tue, Oct 28, 2014 at 5:16 PM, Sun, Ning <address@hidden> wrote:
> Hi,
> I encountered an error when installing grub 2.00 on my Linux system(boot
> from EFI BIOS), the error showed “source_dir doesn't exist. Please specify
> --target or –directory”

That means that you don't have grub support for your platform,
presumably x86_64-efi, installed. You can just install the appropriate
package, grub-efi-amd64 in Debian, to resolve this problem.

> The error occurred after I run this command:
> #grub-install –boot-directory=/boot /dev/sda
> I can compile the grub 2.0 successfully on my linux system.

If you are compiling from source rather than installing via a package
manager, you should run ./configure with the parameter
"--with-platform=efi" to have grub's efi support built.

> Another hint is that currently my linux system use gummiboot as default
> bootloader…
> I run grub-install without parameters , same message shown on the screen

This is not a bug, so please do not CC address@hidden on any future replies.

Jordan Uggla (Jordan_U on

reply via email to

[Prev in Thread] Current Thread [Next in Thread]