[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Freeze at "Loading....." in UEFI environment [SOLVED]

From: Dan McGhee
Subject: Re: Freeze at "Loading....." in UEFI environment [SOLVED]
Date: Sat, 27 Sep 2014 15:01:36 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.1.1

On 09/27/2014 08:57 AM, Dan McGhee wrote:
I build "Linux from Scratch," and am trying to use grubx64.efi to boot LFS-7.4, LFS_7.5, Ubuntu-14.04 and Win-8.1.  At this point, I get the Grub Menu, but when I select any of the OS's, the screen shifts to "Loading <name>....." and stops.  The only action I can take then is CTRL-ALT-DEL.

To check things, I modified Ubuntu's three-line grub.cfg on the EFI partition to point to my LFS-7.5 partition and grub.cfg.  I then can boot any of my OS's.  So it seems that the problem is with either the grubx64.efi that I built or some interface with the efi variables that I don't know about, much less know how to manipulate.  I'm thinking that I made some uninformed mistake with Grub.

Machine info:  HP Envy m6 Sleekbook
Partitions:  Windows-(hd0,gpt1), EFI-(hd0,gpt2), LFS-7.5-(hd0,gpt6), LFS-7.4-(hd0,gpt7), Ubuntu (hd0,gpt8)
I configured Grub with these options: 
<original response snipped here>

I inadvertently hit the wrong button in replying to Andrei Borzenkov's questions.  I'll include a summary here.

Upon query and answer, he told me that the current stable version of Grub was grub-2.02-beta2.  Which I installed and got what I wanted.

The only other thing I added was that I was not able to find this version at but only at from Ubuntu.

Thanks for the help.  I appreciate it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]