[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem after update with grub and --unrestricted on i386

From: Michael D. Setzer II
Subject: Re: Problem after update with grub and --unrestricted on i386
Date: Fri, 05 Sep 2014 16:04:27 +1000

I just rebooted the machine again, and problem is that it doesn't show what 
the file is: just get the message

error: file not found
error: file not found
error: file not found

Press any key to continue

It does then continue after waiting a short time, so one doesn't have to press 
any key. 

I did just find the the grub had some insmod with efi and ieee which where 
not in the /boot/grub2 directory, so commented them out, and that elimanated 
the file not found messages. 

But still not sure about the --unrestricted issue.

Another issue might be that the grub2 directory has lots more files than the 
machines that are running the 64bit versions, and they were clean installs 
while these were older machines that were upgraded to f20 from older 
versions, and it appears they may not had the space after the mbr.

The grub2 is reported as 2.00-26

Have not tried putting the --unrestricted back in the 10_linux file?

Thanks for the reply.

On 4 Sep 2014 at 12:25, Jordan Uggla wrote:

From:                   Jordan Uggla <address@hidden>
Date sent:              Thu, 4 Sep 2014 12:25:37 -0700
Subject:                Re: Problem after update with grub and --unrestricted 
To:                     "Michael D. Setzer II" <address@hidden>
Copies to:              help-grub <address@hidden>

> On Wed, Sep 3, 2014 at 5:36 AM, Michael D. Setzer II
> <address@hidden> wrote:
> > Most of my systems are x64 machines, but have 3 32 bit machines and
> > on these after to a grub2-mkconfig -o /boot/grub2/grub.cfg had the
> > machine giving an error message about --unrestricted being invalid??
> On BIOS based systems grub, at boot, is always 32 bit. So the
> difference you're seeing is not about 32 vs 64 bit, even though they
> seem to be correlated. It may actually be a difference between BIOS
> and UEFI, or more importantly Fedora's UEFI secure boot scheme vs a
> more standard upstream grub configuration in BIOS or UEFI. It could
> also be that even though you have the same version of Fedora
> installed, you (for whatever reason) have a different version of grub
> actually installed as a bootloader (as opposed to the userland tools).
> >
> > I was able to use the edit option to remove it, and then it would
> > boot, but got a number of file not found message. No such problem on
> > the x64 machine. All running Fedora 20 with grub 2.00.
> >
> > The x64 machines have the --unrestricted and it works with no
> > problem. Found that this appears in the 10_LINUX file on the class
> > line. Removed it, and redid the grub2-mkconfig and that gets ride of
> > the rebooting option, but it still shows file not found error
> > messages. Was looking for a log file or something to see what is
> > causing these messages.
> Due to the problems of safely writing to a filesystem, grub does not
> do any logging to disk. For saving logs of error messages your options
> are unfortunately only logging output via serial, taking a picture of
> the screen with a camera, or pen and paper. What files specifically
> are listed as not found?
> -- 
> Jordan Uggla (Jordan_U on
> _______________________________________________
> Help-grub mailing list
> address@hidden

  Michael D. Setzer II -  Computer Science Instructor      
  Guam Community College  Computer Center                  
  Guam - Where America's Day Begins                        
  G4L Disk Imaging Project maintainer
+----------------------------------------------------------+ (Original)
Number of Seti Units Returned:  19,471
Processing time:  32 years, 290 days, 12 hours, 58 minutes
(Total Hours: 287,489)

address@hidden CREDITS
ROSETTA     19340132.238941   |   SETI        32508795.854246
ABC         16613838.513356   |   EINSTEIN    32048217.233631

reply via email to

[Prev in Thread] Current Thread [Next in Thread]