[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PXE booting over IPv6

From: Andrey Borzenkov
Subject: Re: PXE booting over IPv6
Date: Fri, 20 Jun 2014 19:18:14 +0400

В Thu, 19 Jun 2014 13:10:57 -0700
Michael Mohr <address@hidden> пишет:

> Good afternoon;
> I'm attempting to set up an IPv6-based PXE boot environment with iPXE 
> and GRUB.  I've updated the option ROM on an Intel network card using 
> the latest iPXE code (git rev 7fe0735) with IPv6 support enabled.  
> Booting from this card, iPXE is able to auto-configure both a link-local 
> IPv6 address as well as one from radvd (via SLAAC).  iPXE also 
> successfully requests additional parameters from a DHCPv6 server, 
> including the bootfile-url, which allows it to retrieve a copy of GRUB 
> generated as follows:
> address@hidden:~$ grub-mkimage --version
> grub-mkimage (GRUB) 2.02~beta2-9
> address@hidden:~$ grub-mkimage --format=i386-pc-pxe --output=grub.pxe 
> --prefix='(pxe)/boot/grub' \
>  > pxe tftp http cpuid echo gfxterm gzio minicmd normal png vbe
> iPXE successfully downloads the GRUB PXE image from a local HTTP server 
> and transfers control to it.  I am then dropped into a GRUB shell and 
> the boot process stops.  I've tried running "net_ipv6_autoconf", which 
> initially reports "error: couldn't autoconfigure PXE", but if I run it a 
> few times it is eventually able to configure the network interfaces (as 
> shown by "net_ls_addr") with appropriate IPv6 addresses.

grub currently does not send SLAAC solicitation, it passively waits for
SLAAC advertisements, so it depends on how frequently your router sends

> Clearly GRUB isn't able to retrieve its configuration file for some 
> reason.  I've placed one on the HTTP server specified in DHCP as 
> http://[ipv6::address]/boot/grub/grub.conf and am able to retrieve it 
> with a standard web browser.  I suspect that I'm missing something 
> fundamental here, so any enlightenment you can provide is appreciated.

As far as I can tell grub does not use square brackets when parsing
IPv6 address. Try using something like


reply via email to

[Prev in Thread] Current Thread [Next in Thread]