[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Booting from LVM on top of LUKS

From: Kwesadilo X
Subject: Re: Booting from LVM on top of LUKS
Date: Sun, 27 Apr 2014 00:17:46 +0000

Thanks for answering, Andrey.

I tried setting debug=all after the linux command and got maybe half a screen worth of output before hanging. I lack the hardware to attach a serial or network terminal device and capture the whole thing, but here are the last few lines (copied by hand):

script/script.c:50: malloc 0xc366e120
script/script.c:50: malloc 0xc366e0e0
script/lexer.c:321: token 0 text []
script/script.c:50: malloc 0xc366e260
script/script.c:50: malloc 0xc366e220
script/script.c:65: free 0xc366e220
script/script.c:65: free 0xc366e260
script/script.c:65: free 0xc366e0e0
script/script.c:65: free 0xc366e120

The output before what I copied was of the same form as what you see above, i.e. mallocs, frees, or "token X as text []." There were probably around 30 lines in total. As far as I could tell, all of the mallocs had an associated free and vice versa.

I guess the Linux boot parameters are somewhat outside the scope of this list, but I also tried adding "debug" and "initcall_debug" to the linux command line, and this did not produce any additional output prior to the hang.


On Fri, Apr 25, 2014 at 8:40 AM, Andrey Borzenkov <address@hidden> wrote:
On Fri, Apr 25, 2014 at 7:22 AM, Kwesadilo X <address@hidden> wrote:
> Hi,
> I have been trying to set up GRUB to boot Linux from an LVM logical volume
> on top of a LUKS device. This is my system root partition, including /boot.
> I've read various places that GRUB2 supports booting from LVM or LUKS
> volumes, but nothing that seemed too official or that mentioned both at the
> same time. Is this a supported configuration?
> My current status is that I can boot GRUB, GRUB will ask for my encryption
> key, and show the boot menu (from grub.cfg stored in /boot) after I give my
> key. At this point, I can see from the GRUB shell that GRUB has mounted my
> LVM/LUKS volume, and I can see my kernel and initramfs in /boot. I can give
> the initrd and linux commands seemingly without error. But when I give the
> boot command, the system just hangs. Any ideas?

You could try "set debug=all" in grub shell before doing "boot". This
may reveal whether it hangs in grub or after grub passed control to

reply via email to

[Prev in Thread] Current Thread [Next in Thread]