[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Managing multi grub installs

From: Rustom Mody
Subject: Re: Managing multi grub installs
Date: Mon, 10 Mar 2014 20:51:52 +0530

On Mon, Mar 10, 2014 at 12:25 PM, Andrey Borzenkov <address@hidden> wrote:
> В Mon, 10 Mar 2014 08:40:53 +0530
> Rustom Mody <address@hidden> пишет:
>> Hi
>> My earlier thread
>> Thanks to help from Jordan Ugla there, in particular, the suggestion
>> to use 'configfile',  things have been mostly working for the last 2-3
>> years. Recently it stopped working so this mail. More details below.
>> My blkid excerpts
>> /dev/sda2: LABEL="Boot500G" UUID="..." TYPE="ext2"
>> /dev/sda5: LABEL="Debian500G" UUID="..." TYPE="ext4"
>> /dev/sda6: LABEL="Ubuntu500G" UUID="...." TYPE="ext4"
>> /dev/sda7: LABEL="DebOld" UUID="..." TYPE="ext4"
>> In short I have multiple linuxes with their own /boots in sda5,6,7
>> And a /boot standalone in sda2.
>> The mbr points to sda2.
>> sda2 is not mounted in any OS so it does not get meddled with on upgrades
>> It contains entries written by hand like
>> menuentry "Debian  configfile chaining" {
>>         search --set --label Debian500G
>>         configfile /boot/grub/grub.cfg
>> }
>> And this was working for about a year.
>> IOW: the respective OSes would only upgrade their own boots under
>> their respective filesystems.  They would not stomp on each others'
>> toes and my handwritten boot would configfile-chain to them.
> Why do not simply chainload each bootloader? I.e.
> menuentry "Debian bootloader" {
>   search --set --label Debian500G
>   multiboot /boot/grub/i386-pc/core.img
> }

Tried this. I get:

Welcome to Grub (in inverse video)
error file not found
Entering rescue mode
grub rescue>

How I tried:

At the grub prompt I gave the following
multiboot (hd0,5)/boot/grub/core.img

1 Tab expansion expands to that (there is no i386-pc directory)
2 Unlike the configfile that immediately acts (and crashes) this does
nothing until boot is given
3 Help multiboot said not loaded so tried with insmod multiboot. Still the same

> (adjust platform and paths as needed). Or simply configure each OS to
> install bootblock in respective partition and use
> chainloader +1

I dont remember the details but there were a lot of issues with
bootblock-grub when I last tried

Some other things Ive tried:
1. Setting prefix -- same error
2. setting debug=all to see where its failing -- Just too much output
to make out anything and goes on forever until I give Ctrl-Alt-Del

reply via email to

[Prev in Thread] Current Thread [Next in Thread]