[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "not a valid root device" error in UEFI chainloader command

From: Jake Thomas
Subject: Re: "not a valid root device" error in UEFI chainloader command
Date: Wed, 14 Aug 2013 09:16:21 -0700

I had a nearly identical problem yesterday trying to chainload Apple's boot.efi 

As Mr. Murphy pointed out (in another thread), the problem was caused by me 
having a hybrid GPT/MBR setup. Simply changing it back to pure GPT fixed the 
problem. Kudos to Mr. Murphy.

sudo gdisk /dev/sda

x //Enters the Expert menu

n //Creates a new protective MBR

w //Writes - actually does it

Now I can chainload Apple's boot.efi file just fine without the error
"not a valid root device".

The long, long, complex menuentry generated by grub-mkconfig to boot
Mac OS X still doesn't work.

What's weird is that I used to be able to chainload boot.efi with a
hybrid setup no problem. But after updating my Grub efi image (made
from Grub compiled from source from bzr a couple days ago), I got the

Why would it no longer be able to load the efi image off a hybrid
disk? It makes no sense to me because it can still see and read the
file (ls command) off one.

That using the "(${root})" syntax works (for you, I never tried it) makes it 
kinda look like a bug.


Sent from my iPhone

reply via email to

[Prev in Thread] Current Thread [Next in Thread]