[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: new install not booting - solved, but questions remain

From: Andrey Borzenkov
Subject: Re: new install not booting - solved, but questions remain
Date: Sun, 4 Aug 2013 08:34:49 +0400

В Sat, 03 Aug 2013 15:34:12 -0400
Miles Fidelman <address@hidden> пишет:

> Hi Folks,
> Just installed Debian Wheezy onto a remote server, and encountered some 
> problems getting grub to boot properly.  Figured it out through trial 
> and error, but an explanation of what's going on would be very much 
> appreciated.  Note, most of my familiarity is with grub-legacy, this is 
> my first time working through things with grub 2.
> Basic setup:
> - remote install via IPMI console and later via ssh
> - PXEboot into the installer
> - partition and configure 4 disk drives into md devices for boot, swap, 
> root, LVM
> - USB drive shows up as /dev/sda during install - with hard drives as 
> /dev/sdb-e
> - after install hard drives show up as /dev/sda-d, usb drive as /dev/sde
> - pretty standard install process until the end
> - had to fiddle a bit to install MBR into hard drives (default would 
> have put it on the USB)
> - attempt to boot, end up at grub prompt on the remote console
> - type "boot" and get "error: no kernel loaded"
> - did some googling, based on what I found, tried the following (from 
> the grub> prompt)
> -- set prefix=(md/0)/boot/grub
> -- set root=(md/2)
> -- boot
> -- still get "error: no kernel loaded"
> -- noted that ls (md/0)/ showed, config-, vmlinuz, initrd as 
> well as grub
> -- tried the command "linux (md/0)/vmlinuz..." - let it autocomplete the 
> full file name
> ----- got "error: file not found"  #THIS IS CONFUSING - SINCE LS AND 
> -- insmod normal
> -- insmod
> ------ now I get a boot screen, and after the timeout, everything booted 
> normally
> - reboot brought be back to the grub> prompt
> - this time, after booting:
> -- ran update-grub and grub-install on all four drives, and and on 
> /dev/md0 (boot) and /dev/md2 (root) for good measure
> -- rebooted - everything came up fine So problem is solved but 2 questions
> But I'm left with two questions:
> - What exactly is going on? (WHY did the above fix the problem?)

core.img generated during installation contained wrong reference
to /boot/grub directory (most likely incorrect disk designation). It is
impossible to say more with information you provided. When you rebuilt
it, it apparently picked up the working one (again, I won't say
"correct one" because we do not know it).

> - Why didn't the install set things up properly? (This one is really a 
> question for the debian-boot list, and perhaps a bug report - but I'd 
> kind of like to understand what's going on with grub, and what should be 
> installed, before focusing on the installer.)
> Thanks very much,
> Miles Fidelman
> _______________________________________________
> Help-grub mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]