[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Why USB command doesn't return usb devices list ?

From: Jordan Uggla
Subject: Re: Why USB command doesn't return usb devices list ?
Date: Fri, 7 Jun 2013 14:27:02 -0700

On Thu, May 30, 2013 at 12:29 AM, Emad Elsaid <address@hidden> wrote:
> i have the following problem :
> i have a brand new HP ProBook 4540s, installed windows8 then ubuntu 13.04
> so GRUB2 is installed to my HDD successfully
> each of the OSs loads correctly.
> now i'm trying a small experiment the goal is make grub boot the OS after
> finding a usb stick with
> a certain serial number.

What is your end goal? It would be simpler to detect a drive
containing a filesystem with a certain UUID, or a specific file.

> checked GRUB2 command list and found "USB" which should list all USB devices
> i have.
> so i started my Laptop, pressed "C" to enter GRUB command line, executed
> "usb"
> while having a USB Flash stick connected but the command always return empty
> list
> like it cannot find any USB devices,
> note the i tried the following and the result is the same :
> - tried all USB ports
> - tried "insmod usb", "insmod usbtest"

"usb" is a generic module meant to use "ohci" "uhci" or "echi" to
actually access USB devices useing those protocols (the two USB 1.0
protocols and the USB 2.0 protocol respectively) so you'll need to
load the appropriate module (or just load all of them) to actually
access any USB devices.

Jordan Uggla (Jordan_U on

reply via email to

[Prev in Thread] Current Thread [Next in Thread]