[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trying to use Grub Command Line to boot from CD

From: Jesse Thompson
Subject: Re: Trying to use Grub Command Line to boot from CD
Date: Fri, 7 Jun 2013 07:46:23 -0700

(I think I accidentally replied to poster instead of list on this one last night, so reposting)

I am 90% certain it's grub2. The machine was running some variant of Lenny or Squeeze Debian before I made an ill-advised upgrade, I'm pretty sure Debian upgraded from grub1 to grub2 back in the days of sarge or etch. That was it's own fresh hell, I recall. ;)

From here I can't get to my linux boot environment to check via dpkg. I think the environment is keyed toward a 3.x kernel thus my 4 other 2.6 variants are also unbootable. Also spent this evening trying out tomsrtbt floppy. Grub displays (fd0) as an item and disk drive lights when I try to ls (fd0), but then it says "Device fd0: Filesystem cannot be accessed // error: no such disk". Same error as empty drive. Floppy mounts fine in other computers and passes "badblocks -w" test, I suspect it could be tomsrtbt's 1.8MB hack. This ancient server may not support the additional capacity. *shrugs*

When I run "help" at grub command line I don't see any "version" command or similar to clarify 1.98 vs 1.99 or such. If there is a way to discern from grub> prompt, or if that's relevant then I'm all ears. :)

- - Jesse

On Thu, Jun 6, 2013 at 7:43 PM, Andrey Borzenkov <address@hidden> wrote:
Which grub version is installed?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]