[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot anymore boot into ubuntu

From: Andrey Borzenkov
Subject: Re: cannot anymore boot into ubuntu
Date: Sat, 13 Oct 2012 14:09:51 +0400

On Sat, Oct 13, 2012 at 1:36 PM, Averlon <address@hidden> wrote:

I have a configuration with two HDDs.
First HDD = encrypted Windows (Truecrypt)
Second HDD = encrypted Ubuntu + encrypted NTFS partition

It worked to boot into ubuntu by selecting the second hdd in the bios boot-menue. To boot into ubuntu via the Truecrypt boot-menue does not work - but I don't care at the moment.

After some system upgrade (apt-get update && apt-get upgrade) I answered a question regarding grub the wrong way and now I am not anymore able to boot into ubuntu.

With supergrub-disk I am able to start ubuntu. But I cannot get grub2 installed on the mbr of the second hdd.

NAME                           MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                              8:0    0  29,8G  0 disk  
├─sda1                           8:1    0   100M  0 part  
└─sda2                           8:2    0  29,7G  0 part  
sdb                              8:16   0 465,8G  0 disk  
├─sdb1                           8:17   0     2M  0 part  
├─sdb2                           8:18   0   200M  0 part  /boot
├─sdb3                           8:19   0 152,4G  0 part  
│ └─sdb3_crypt (dm-0)          252:0    0 152,4G  0 crypt 
│   ├─lvm_crypt-swap_nb (dm-1) 252:1    0   4,9G  0 lvm   [SWAP]
│   └─lvm_crypt-root_nb (dm-2) 252:2    0 147,5G  0 lvm   /
└─sdb4                           8:20   0 313,2G  0 part

grub-setup /dev/sdb
grub-setup: Warnung: This GPT partition label has no BIOS Boot Partition; embedding won't be possible!.
grub-setup: Warnung: Einbettung ist nicht möglich. GRUB kann in dieser Konfiguration nur mittels Blocklisten installiert werden. Blocklisten sind allerdings UNZUVERLÄSSIG und deren Verwendung wird daher nicht empfohlen..
grub-setup: Fehler: mit Blocklisten wird nicht fortgesetzt.

I neither can identify the message I get nor find a solution for that.

And could you show "fdisk -l /dev/sdb"? GRUB2 believes this is GPT diks. If it is true, you need to either create BIOS Boot Partition to embed grub2 or use --force to continues with (not recommended) blocklist.
To recall: After basic installation of the whole environment it worked. But you might imagine to delete the second hdd and start from scratch is not the very best solution for me.

I would appreciate any help.



Mit freundlichen Grüßen / Kind Regards

Karl-Heinz Fischbach



Tel.: +49 (8121) 7922532

Skype: khfischbach
jabber: address@hidden

Diese e-mail ist unter Umständen signiert. Die Signatur entspricht dem Deutschen Signaturgesetz und entsprechenden europäischen Regelungen.
Important Note:
This e-mail may contain trade secrets or privileged, undisclosed or otherwise confidential information. If you have received this e-mail in error, you are hereby notified that any review, copying or distribution of it is strictly prohibited. Please inform us immediately and destroy the original transmittal.       

Help-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]