[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: installed on USB -- must change port after update (but no ports left

From: Carnë Draug
Subject: Re: installed on USB -- must change port after update (but no ports left)
Date: Mon, 8 Oct 2012 17:06:20 +0200

On 8 October 2012 16:29, Carnë Draug <address@hidden> wrote:
> Hi everyone
> I have Debian installed with GRUB2 on a USB stick. However, it seems
> that after an update (it runs grub-mkconfig -o /boot/grub/grub.cfg), I
> can no longer boot from the USB port. When the BIOS lists the boot
> options, it doesn't even show my USB stick anymore.
> I'm of course not sure if this is the cause of my problems but I don't
> know what else can be. I have this PC only temporarily that has 2 USB
> ports. It booted fine before, no problem. One day, after an update, I
> could no longer boot. I tried the other USB port which was ok so I
> didn't gave it anymore thought (but the other USB port still works.
> After booting, I can connect external drives to it for example). This
> morning, after another update, I also can't boot from this second USB
> port. I tried the 1st again bt still nothing. So the PC is useless for
> me now. I can't boot on my system anymore.
> I was wondering if it's possible that when creating a new grub conf
> file, it somehow blacklists that port, identifies it as an HD,
> something like this. How can I solve this? Or prove that the issue if
> not with GRUB at all? Any help would be very welcome.
> Thanks in advance,
> Carnë

So I just made a quick test that shows the problem must be with some
GRUB configuration. I booted into my USB stick from a friend computer.
Worked fine. I then ran update-grub, restarted the PC and could no
longe rboot from the USB. What should I change on grub.cfg? I look at
it but don't see anything  suspicious.

I have pastebined the file at


reply via email to

[Prev in Thread] Current Thread [Next in Thread]