[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub-install to /dev/vda (MBR!) suddenly fails

From: Juha Kallio
Subject: grub-install to /dev/vda (MBR!) suddenly fails
Date: Mon, 16 Apr 2012 19:42:32 +0300
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20120327 Thunderbird/11.0.1


I have migrated to grub2 from grub-legacy, and have had a working installation in a virtual machine for a while. Today I updated the Debian wheezy installation, and now grub-install to /dev/vda fails with the following error:

/usr/sbin/grub-setup: warn: Attempting to install GRUB to a disk with multiple partition labels or both partition label and filesystem. This is not supported yet.. /usr/sbin/grub-setup: warn: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
/usr/sbin/grub-setup: error: will not proceed with blocklists.

This is a virtio disk from KVM, and should only have a basic partition table that was created on install. fdisk -l /dev/vda confirms that with the following information:

Disk /dev/vda: 6442 MB, 6442450944 bytes
16 heads, 63 sectors/track, 12483 cylinders, total 12582912 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d70a5

   Device Boot      Start         End      Blocks   Id  System
/dev/vda1   *        2048     8386559     4192256   83  Linux

I haven't tried to boot this virtual machine yet. I also haven't tried the --force flag, since I shouldn't be restricted to using blocklists. I can grub-install to another device, /dev/sda, but for some reason the actual boot device doesn't work anymore as a target for grub-install.

I'm sorry if this problem would be more suited to Debian mailing lists.

Juha Kallio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]