[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Add Grub2 menu item without booting into GNU/Linux

From: Joshua Fox יהושע פוקס
Subject: Re: Add Grub2 menu item without booting into GNU/Linux
Date: Tue, 1 Nov 2011 18:41:39 +0200


Thank you! That did it! I used your instructions to mount my original Ubuntu partition as root. 

However, grub-mkconfig and update-grub left things as before.

The deeper problem was that Grub Customizer had overwritten my /etc/grub.d/10_linux configuration, replacing it with a pointer to  /etc/grub.d/proxifiedScripts/linux . See

Thus, with every attempt to rebuild the  Grub2 configuration, whether with Rescatux, Boot Repair, or console commands, these incorrect settings created by Grub Customizer were used.

So, I had to mv /etc/grub.d/proxifiedScripts/linux /etc/grub.d/10_linux, and only then run  grub-mkconfig and update-grub.

Now, in my boot menu, the latest kernel still appears twice, the second time as an "earlier version." This is a bit annoying, but I will live with it instead of trying to fix it again!



On Tue, Nov 1, 2011 at 2:56 PM, Robert <address@hidden> wrote:
Joshua Fox יהושע פוקס wrote:

I am trying to set up my Grub2 with Ubuntu 11.10.

Grub2 was working, until I removed old kernels with Grub Conf.
Though I took care not to remove the latest kernel, I find they
are all missing.

your (sdb1)/boot/grub/grub.cfg  yet doesn't have a Linux boot entry on it. Just 2 memtest and XP Home. You erased too much.

So, everything is OK-- but until I  add Ubuntu back into the Grub2
boot menu, I cannot boot into it. (Some other entries, including
memcheck and Windows, remain on the menu.)

I tried Boot Repair, with no improvement: Here are the details on
my machines boot configuration

I also tried reconfiguring Grub2 after booting in LiveCD, to no avail.

How exactly?

In your live Environment you can simply mount your partitition with /boot on, and edit the /boot/grub/grub.cfg  - if you know what to add.

A) Yet, with your live CD you should be also able to boot your existing system (with live kernel). e.g. I know from Debian Live:
Press Tab on an apropriate Live boot menu entry, then you see a boot line, then replace all the options on the boot line with just e.g. root=/dev/sdb1 like:
"/live/vmlinuz <dont exactly remember> /live/initrd.img root=/dev/sdb1"

B) Also with the install CD you should have a resuce option to start a "shell in the target environment" or so.

C) Or in Live shell:

mount /dev/sdb1 /mnt
mount -o bind /dev /mnt/dev
mount -o bind /sys /mnt/sys
mount -o bind /proc /mnt/proc
chroot /mnt

=> then you are almost in your system "AS IF" you had booted into - at for this shell instance, in order to run update-grub or liloconfig.

As soon as you are into your Linux system/shell by A B or C, backup your grub.cfg, and re-run "update-grub". this auto-creates a rather complete grub.cfg, you can (reboot and) then again try to strip down the grub.cfg.

Or switch to LILO on that chance: "liloconfig".
LILO unlikely creates any such trouble (in the future). /etc/lilo.conf can be edited decently and all is rather clear and simple. And important: anytime you run lilo to really make your edits active (They are not before), LILO checks things actively or gives you errors or warnings BEFORE reboot. It doesn't install upon errors. And 99.9% doesn't install a unwanted/non-functional bootloader configuration, as you get feedback on the "lilo" run.

What do I have to do?



Help-grub mailing list

Attachment: 10_linux
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]