[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: black screen / blinking cursor after grub-install

From: J.V.
Subject: Re: black screen / blinking cursor after grub-install
Date: Thu, 11 Aug 2011 16:35:29 -0600
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110624 Thunderbird/5.0

How do I tell which version of grub CentOS 6 ships with?

Also is it possible some how to use/install the latest version and get that going with CentOS? I do need specific documentation on how to do this if it is available.



On 8/11/2011 4:24 PM, Mads Kiilerich wrote:
J.V. wrote, On 08/12/2011 12:11 AM:

On 8/10/2011 9:33 PM, Jordan Uggla wrote:
On Tue, Aug 9, 2011 at 1:13 PM, J.V.<address@hidden>  wrote:
Just to follow up on the previous post.

I have a black screen with a single blinking cursor after running:
    #grub-install /dev/sda1
Never install grub's boot sector to a partition, install it to the mbr
instead (/dev/sda).

I tried to do that just now, and it did not work. I am looking for additional solutions to make my system boot and undo what #grub-install /dev/sda1 did

I tried using the CentOS 6 media in rescue mode to do this and got this error
#grub-install /dev/sda

/sbin/grub: Not found.

=> so that is not possible with the CentOS 6 boot cd in rescue mode.

Try to mount your root partition somewhere, mount /boot, /proc and /sys, and then chroot to your system and run grub there.

(Btw: You are probably using Red Hats grub 0.97 which isn't supported here upstream.)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]