[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Interactive - Manually booting up the kernel

From: shirish शिरीष
Subject: Interactive - Manually booting up the kernel
Date: Mon, 23 May 2011 18:11:23 +0000

Hi all,
       I am running grub version 1.99-4 .

$ dpkg -l grub-pc
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
ii  grub-pc        1.99-4         GRand Unified Bootloader, version 2 (PC/BIO

I am trying to run grub in interactive mode (which means it outputs
stuff a screenful) and then I can see what is going right or wrong.

I saw the info.grub and came to know about  pager=1 thing.

I did see the files /etc/default/grub and /boot/grub/grub.cfg

I do not understand why the pager=1 option does not work.

What I tried to do is on the grub-menu use e to edit 2.6.39. kernel
menu entry and modified the line from :-

linux   /boot/vmlinuz-2.6.39-1-amd64 root=UUID=somealphanumericUUIDno
ro init=/sbin/bootchartd quiet


linux   /boot/vmlinuz-2.6.39-1-amd64 root=UUID=somealphanumericUUIDno ro
init=/sbin/bootchartd pager=1

The change was just from 'quiet' to 'pager=1' . Then to boot pressed
F10. While the booting happened, it did not halt/pause after
information of 1 screenful had passed.

Can somebody tell me what am I doing wrong ?

Btw I also tried using :-

linux   /boot/vmlinuz-2.6.39-1-amd64 root=UUID=somealphanumericUUIDno ro

as well as

linux   /boot/vmlinuz-2.6.39-1-amd64 root=UUID=somealphanumericUUIDno ro pager=1

both these options also did not work.

Looking forward to info.
          Shirish Agarwal  शिरीष अग्रवाल
  My quotes in this email licensed under CC 3.0
065C 6D79 A68C E7EA 52B3  8D70 950D 53FB 729A 8B17

reply via email to

[Prev in Thread] Current Thread [Next in Thread]