[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub2 on NTFS: error: INDX label not found.

From: Patrick Strasser
Subject: Grub2 on NTFS: error: INDX label not found.
Date: Fri, 04 Feb 2011 22:01:46 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv: Gecko/20101207 Lightning/1.0b3pre Mnenhy/0.8.3 Thunderbird/3.1.7


I'm trying to install grub2 (Debian unstable) to a USB external HDD. It
is a WD with 2 TB size. I intend to install Ubuntu from a ISO image via
the loopback method. The HDD has one partition filling the the whole
disk, NTFS formated. I want to keep it like that.

I installed the Grub with following commands:
mount /dev/sdc1 /mnt
grub-install --root-directory=/mnt /dev/sdc

No errors reported, boot/grub directory on /mnt, everything fine.

I put a preliminary grub.conf into boot/grub/, namely

After booting from the disk I get:

GRUB loading.
Welcome to GRUB!

error: INDX label not found
Entering rescue mode...
grub rescue>

-- I tried to find the grub.cfg file by hand:
grub rescue> ls
(hd0) (hd0,msdos1) (hd1) (hd1,msdos1) (hd1,msdos5)
-- note: hd1 is my internal disk, ext2 and swap partitions
grub rescue> set root=(hd0,msdos1)
grub rescue> ls /
-- <Listing of NTFS root directory, with $-directories, and boot>
grub rescue> ls /boot
grub rescue> ls /boot/grub

error: INDX label not found.
grub rescue>

AFAIU INDX entries are the directory entries in NTFS, listing the
contents of directories.
I thought that maybe the Linux driver got something wrong. So I created
under Windows XP boot2/grub, copied all files over from boot/grub,
deleted boot/grub and renamed boot2 to boot. Still the same problem.

Any ideas anyone?


Engineers motto: cheap, good, fast: choose any two
Patrick Strasser <patrick dot strasser at student dot tugraz dot at>
Student of Telemati_cs_, Techn. University Graz, Austria

reply via email to

[Prev in Thread] Current Thread [Next in Thread]