[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Control PXE Device

From: Johnson, Je
Subject: Control PXE Device
Date: Wed, 12 Jan 2011 13:12:22 -0500

My questions is pertaining to the control of a PXE device by using the “pxe –info” to help determine client ip, server ip and gateway information. I’ve compiled and successfully installed GRUB2 1.98 and the PXE configuration is working properly.


My “grub2pxe” image was created by the following command and loads the “pxe” and  “pxecmd” modules:


grub-mkimage –output=core.imt –prefix=”(pxe)/boot/grub” pxe pxecmd

cat pxeboot.img core.img > grub2pxe


During the startup sequence I’ve been press “c” to drop me to the grub prompt. From the grub prompt I ran the “lsmod” to ensure that the pxe and pxecmd modules were loaded.


When I run the following command “pxe --info” I get the following error:


error: unknown command ‘pxe’.


I’m not sure why the “pxe” command is not found since it’s been loaded “pxe.mod”. I ran the “strings” command on the pxe.mod and that’s where the “net_pxe_ip” lives.


Any help on why the pxe command is not found under the grub prompt would be greatly appreciated.



John Johnson

Lockheed Martin

Manassas, VA



reply via email to

[Prev in Thread] Current Thread [Next in Thread]