[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Still issues with Grub2 and (k)FreeBSD

From: Hannes Hauswedell
Subject: Re: Still issues with Grub2 and (k)FreeBSD
Date: Fri, 3 Dec 2010 14:17:19 +0100
User-agent: KMail/1.13.5 (FreeBSD/8.0-STABLE; KDE/4.5.1; i386; ; )

On Monday 29 November 2010 23:09:15 Hannes Hauswedell wrote:
> Hi everyone,
> since my last PR <> (still offline
> right now), I still couldn't make Grub2 boot FreeBSD. The issue from
> the PR was resolved the way explained in the post, thanks.
> Since I am not sure this is a bug, I thought I'd ask first before
> opening one.
> Is it possible that Grub2 does not pass Networking Information to the
> FreeBSD-Kernel, i.e. the information it has received via DHCP / PXE ?
> I am booting Grub2 through PXE/TFTP and it successfully loads and and
> also boots the FreeBSD-Kernel, however the FreeBSD-Kernel always
> fails to mount root from NFS. I have tried all sort of fiddling with
> the FreeBSD Kernel and am pretty sure its not its fault.
> The FreeBSD-Kernel can be compiled with BOOTP_NFSROOT, to make it re-
> request root-path and server for this case, however going that way is
> not an option, because I cannot transmit root-path (Option 17 in
> dnsmasq), if I want to offer multiple Operating systems as choice.
> Note also that the dnsmasq-server and NFS-Server are on two
> machines.
> Thank you very much for your help,

Hi again,

I don't know if there were answers yet, I am not subscribed. Please CC 

On a different note, I tried to boot Debian_SID from the Server, which 
also fails with completely different issues. It doesn't even load the 
kernel it just hangs. On the tftp-Server I see the stuff attached.

I did a lot of googling on that, but didn't really find an answer. It 
ranges from "not an error, don't worry"[1], to "its fatal and the 
network hardware's fault or PXEGrub can't andel Gbit-Cards"[2].

Obivously the first isn't true, since it doesn't work. Obviously the 
second isn't true, since it can load the freebsd-kernel and modules 
without issues.

Thanks for your help,
Best Regards,            │ Free Software Foundation Europe    █▉   │
Hannes Hauswedell        │           German Team            █▉█▉█▉ │
                         │ Coordinator for     ▉▉   │


Attachment: dnsmasq.log
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]