[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub2 on ubuntu 10.10 can't find loader on 1st partation

From: Tom H
Subject: Re: grub2 on ubuntu 10.10 can't find loader on 1st partation
Date: Mon, 25 Oct 2010 09:37:39 -0400

On Sun, Oct 24, 2010 at 5:06 PM, tom oakes <address@hidden> wrote:
> I have a computer configured with 2 disk drives configured as follows: shown
> with parted -l ubuntu:
> Model: ATA Hitachi HDS72101 (scsi)
> Disk /dev/sdb: 1000GB
> Sector size (logical/physical): 512B/512B
> Partition Table: msdos
> Number  Start   End     Size    Type      File system     Flags
> 1      32.3kB  252GB   252GB   primary   freebsd-ufs     boot
> 2      252GB   503GB   252GB   primary   freebsd-ufs
> 3      503GB   755GB   252GB   extended                  lba
> 5      503GB   745GB   242GB   logical   ext3
> 6      745GB   755GB   9973MB  logical   linux-swap(v1)
> 4      755GB   1000GB  245GB   primary
> As reported from freebsd fdisk -s :
> # fdisk -s
> /dev/ad4: 1938021 cyl 16 hd 63 sec
> Part        Start        Size Type Flags
>  1:          63   491519889 0xa5 0x80
>  2:   491519952   491519952 0x83 0x00
>  3:   983042046   491515906 0x0f 0x00
>  4:  1474559856   478965312 0x83 0x00
> Freebsd 8.1 is installed on the 1st slice of the 1st partition of the big
> disk. Fresh install.
> ubuntu 10.10 is installed in the logical partition 5 of the extended
> partition 3. Fresh install.
> grub version 2.6.35-22.
> ubuntu  boots correctly when booting from the hard disk with grub2, but I
> have been unable to configure
> grub2 to boot freebsd.
> I can boot freebsd with a cd that I made with grub-legacy while attempting
> to install grub on
> freebsd. I was never able to get freebsd to boot from the hard disk with
> grub-legacy or grub2 installed on freebsd.
> I am able to mount, read only, successfully the freebsd partition from
> ubuntu.
> As you can see in the grub.cfg copied below that ubuntu is loaded from set
> root='(hd1,msdos5)' This works, but is not consistent with what is returned
> by ls from the grub command line.
> (hd0) (hd0,msdos6) (hd0,msdos5) (hd0,msdos4) (hd0,msdos2)
> (hd0,msdos4,msdos1) (hd0,msdos1) (hd1) (hd1,msdos1)
> A set from the grub command line shows: root=hd0,msdos5
> Editing the set root and executing from the  splash screen I have tried
> these, (hd1,msdos1.msdos1) and (hd0,msdos1.msdos1),. I alway get an error.
> Usually the error is: "No such Partition", sometime something about not
> finding the file. There is a file /boot/loader on the first slice of the
> first partition.
> I can not use the chain loader as the MBR  for the big disk contains the one
> from ubuntu not from freebsd.
> I have not tried to put the commands to do a direct boot with code like like
> below, from, as the problem
> seems to be finding the loader file, not executing it.
> menuentry "FreeBSD ad4, direct" {
>                insmod ufs2
>                set root=(hd0,1,a)
>                search --no-floppy --fs-uuid --set 4b22f9090565ab77
>                freebsd                 /boot/kernel/kernel
>                freebsd_loadenv         /boot/device.hints
>                set FreeBSD.vfs.root.mountfrom=ufs:/dev/ad4s1a
>                set FreeBSD.vfs.root.mountfrom.options=rw
>        }

So, at the grub cli, sdb=hd0...

How about (hd0,msdos1,bsd1)?

You should be able to get "/dev/ad4s1a"'s "(hd...)" with "grub-probe
--target=drive --device /dev/sdbXY"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]