[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub2 Problems, Raid 1 with ext4 won't boot

From: compeilermail-bla
Subject: Grub2 Problems, Raid 1 with ext4 won't boot
Date: Tue, 31 Aug 2010 15:09:16 +0000 (GMT)


I received from a friend an installation of edubuntu (Ubuntu 10.04). I just had 
to set up a RAID 1. All seems to have worked fine. I can access all my mirrors 
and they are in sync.

My configuration:
md0 sda1/sdb1 --> /boot --> ext2
md1 sda2/sdb2 --> / --> ext4
md2 sda3/sdb3 --> swap

Where I have my problems is booting the system. Accessing the data on md0/md1 
is possible from Live CDs as Knoppix.

I tried several things, but I think that grub2 has problems finally with the 
ext4 Filesystem.

1.) update-grub and grub-mkconfig aren't working, as you can't direct them to 
other places of the root Filesystem
2.) chroot and update-grub or grub-mkconfig resulted also in an error
3.) grub-install from the live-cd or knoppix also not resulted as expected.
I tried "grub-install --root-directory=/dev/md1 --modules=mdraid /dev/sda" 
(also tried instead of sda /dev/md1 but not with more success)

So I tried also using the rescue mode of grub2 in which at least I entered...
I tried the following:

set prefix=(hd0,1)/grub
set root=(hd0,2)
insmod (hd0,1)/grub/linux.mod --> at least this succeded
linux /vmlinuz root=/dev/md1 ro--> no such file (but in / of md1 exists a 
neither works: linux (hd0,2)/vmlinuz --> no such file

I do not know how to continue. Please help. Hope I don't have to change ext4 to 
something else. Nor to change grub2 back to grub1...

Another point I wanted to know if the above will work: is it possible to make 
an entry in grub2 to make a network boot?

Thanks in advance...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]