[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub-setup: error: no mapping exists for ... in GRUB2 v1.97.1 on fak

From: Lapohos Tibor
Subject: Re: grub-setup: error: no mapping exists for ... in GRUB2 v1.97.1 on fake (IMSM) RAID
Date: Sun, 27 Dec 2009 17:50:35 -0800 (PST)

Thanks for your reply.
What the OROM says is that both of my volumes are bootable.
/dev/md126 corresponds to Volume0, and its first partition (ext4) has the boot flag set.
My problem is that I cannot get grub2 installed on the device at all. I did try, as you suggested, to set
(hd0) /dev/md126
in the file and then issue
> grub-install --modules=raid /dev/md126
but I still get the same error message(s):
grub-probe: error: no mapping exists for 'md126'
grub-setup: error: no mapping exists for 'md126'
What is interesting is that, at the grub shell, I can do
grub> probe -l (hd0,1)
it returns "OS" which is the label I set for it, so the device can, under certain circumstances, definitely be detected. Nevertheless, grub-install does not seem to behave the same way.

--- On Sun, 12/27/09, Michael Evans <address@hidden> wrote:

From: Michael Evans <address@hidden>
Subject: Re: grub-setup: error: no mapping exists for ... in GRUB2 v1.97.1 on fake (IMSM) RAID
To: "Lapohos Tibor" <address@hidden>
Cc: address@hidden
Date: Sunday, December 27, 2009, 7:26 PM

On Sat, Dec 26, 2009 at 5:33 AM, Lapohos Tibor <address@hidden> wrote:
Hello All,
I have 2 SATA disks in an Intel Matrix RAID setup. It contains two volumes, one in RAID1, the other in RAID0 configuration. These I created using the Option ROM of the motherboard,  partitioned using cfdisk, and finally assembled into RAID devices using mdadm v3.0.3. As such, I obtained the following devices:
/dev/md127 (the container to which /dev/md/imsm0 is pointing)
/dev/md126 (the RAID1 "Volume0" pointed at by /dev/md/Volume0)
/dev/md126p1 (the first partition intended to serve as the root fs)
/dev/md126p2 (intended for user space)
/dev/md126p3 (intended for swap)
/dev/md125 (the RAID0 "Volume1" pointed at by /dev/md/Volume1)
/dev/md125p1 (intended for user scratch space)
/dev/md125p2 (itended for swap)
(the long names came from mdadm v 3.0.3).
If I boot from my USB memory stick, and make a stop at the grub shell, I can see all these partitions listed as (hd1) (hd1,[123]), (hd2) and (hd2,[12]), while my USB stick comes up under (hd0) and (hd0,[12]). Therefore, I would dare to say that grub does detect these devices.
I tried to install grub 1.97.1 on /dev/md126 by countless ways without success. The command
$ grub-install --modules=raid /dev/md126 
for example returns the error message
$ grub-setup: error: no mapping exists for "md126"
The /boot/grub folder got created correctly, but the "" file does not mention any virtual RAID devices. It reads:
(hd0) /dev/sda (SATA1)
(hd1) /dev/sdb (SATA2)
(hd2) /dev/sdc (USB flash memory stick)
which, by the way, does not resemble what the
sh: grub> ls
command returns before booting (see the list described before).
Do I need to give up using "fake RAID" and turn to pure SW RAID to get the system up and running, or is there a way to install GRUB2 in this configuration?
Your help is much appreciated. Thanks ahead,

Help-grub mailing list

If you -know- that given drives will be in some positions during startup then you can edit the file your self to tell grub where things will be on reboot.

You should only provide the containers; however a very important question exists.  Are you able to select one of those containers as your boot volume within the bios?  If so make it like that and tell grub that the volume is 'hd0' instead of /dev/sda.  Then you can do the usual setup/install and it should work when using that

-----Inline Attachment Follows-----

Help-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]