[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GRUB - only Centos installer is able to install right ?

From: Vilius Mockūnas
Subject: GRUB - only Centos installer is able to install right ?
Date: Wed, 4 Mar 2009 08:54:50 +0200


I have big problems booting grub from HDD partition boot sector.

Disks - BIOS layout:
SATA RAID1 Volume (ICH9R) 36GB
IDE Master 500Gb #my target disk

Target disk Partitions(only those I use):
hda2 1Gb - primary(past 1024 cylinders), mounts on /boot ext3 - here I install grub
hda6 4Gb - logical, linux swap
hda9 28Gb - logical, mounts on / ext3

I install grub into partition boot sector and chainload to it from other bootloader whitch resides in 270Gb SATA disk MBR. This is not first test:
Slackware 12.2 + LILO - boots this way
Centos 5.2 + GRUB - boots this way
Debian 5.0 - boots from GRUB floppy (see below).

So, Installed Debian 5.0 and grub legacy using debian installer. Was unable to boot - got "GRUB _" with no reaction to any input.
So I made GRUB floppy and tried to boot debian - booted with no problems.
Next I Installed GRUB to HDD from GRUB shell (booted GRUB shell from floppy), commands I used (there was /grub/stage1 and /grub/stage2 files on hda2):
root (hd3,1)
setup (hd3,1) #tried "setup (hd3,1) --force-lba" also

GRUB installed successfully except stage1_5(it should be that way as I remember). I don't use menu.lst so I should get GRUB shell after booting. So I tried to boot from hda2 and again got "GRUB _" with no reaction to any input.

As I mentioned before Centos 5.2 + GRUB installs and BOOTS!! just fine on exactly the same setup. I noticed few not standard things about centos setup(according to me): It allows to install grub only to partition of first disk(according to BIOS order) - so I had to reorder disks temporary. Also it installs successfully only if I supply BIOS disk order mentioned above. So it works.

What I'm doing wrong - why I'm unable to get grub shell after manual install ?
And most interesting question:
What centos installer does so special that it works ?

thanks in advance

reply via email to

[Prev in Thread] Current Thread [Next in Thread]