[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub error 2

From: Bernd Kloss
Subject: grub error 2
Date: Wed, 12 Nov 2008 23:27:23 +0100
User-agent: KMail/1.9.9

Debian Etch


trying to locate a problem mounting PDA to SAMBA I tried to reinstall my old 
ETCH as I did many times before. This time I am running into a stage 1 error 
when booting the recoverd ETCH.

What I did so far:

I copied the backupfile of etch to hda1, which is flagged bootable - okay.

I booted from a SuSE 9.3, login root
cd /
mkdir /hda1
mount /dev/hda1 /hda1
mount -t proc proc /hda1/proc
mount -o bind /dev /hda1/dev
chroot hda1

From here on I tried several strategies:

grub-install /dev/hda1
==> checking if "/boot/grub/stage1" exists no

root (hd0,0)
setup (hd0)
==> error 2 bad file or directory

dpkg -P grub
deleted the /boot/grub
dpkg -i grub_*_.deb
success and grub-install (as above)

The grub-manual says that these errors are related with not finding/reading 
the mini-grub-image placed in the boot sector. This should point to the stage 
1.5 which is supposed to load stage 2.

Is anybody out there with an idea what went wrong and how to fix it?

Thank you

reply via email to

[Prev in Thread] Current Thread [Next in Thread]