[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing gcc4.3.0 without root

From: Lionel B
Subject: Re: Installing gcc4.3.0 without root
Date: Mon, 7 Jul 2008 08:04:42 +0000 (UTC)
User-agent: Pan/0.132 (Waxed in Black)

On Sun, 06 Jul 2008 06:04:38 -0700, daviddoria wrote:

> When I run './configure' i get this error
> configure: error: Building GCC requires GMP 4.1+ and MPFR 2.2.1+. Try
> the --with-gmp and/or --with-mpfr options to specify their locations.
> Copies of these libraries' source code can be found at their respective
> hosting sites as well as at
> See also for additional
> info. If you obtained GMP and/or MPFR from a vendor distribution
> package, make sure that you have installed both the libraries and the
> header files. They may be located in separate packages.
> so i did
> rpm -qa | grep gmp
> gmp-4.1.4-3
> rpm -qa | grep mpfr

Is there perhaps a mpfr-devel package? (you don't say what your 
(presumably Linux) distribution is.

> so this is good... I download, configure, and make mpfr in
> /home/dave/mpfr

Did you do a `make install' too? How did you configure mpfr? If you want 
to install mpfr in /home/dave/mpfr you would likely want to configure it 
with `--prefix=/home/dave/mpfr' (or some such) then `make' then `make 

> then I try to configure gcc again with ./configure
> --with-mpfr=/home/dave/mpfr
> and it gives the same error!! I don't know what else to try - any
> suggestions?
> Thanks!
> Dave

Lionel B

reply via email to

[Prev in Thread] Current Thread [Next in Thread]