[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Determining whether gnunet is connected

From: Maxime Devos
Subject: Re: Determining whether gnunet is connected
Date: Wed, 02 Mar 2022 19:59:06 +0100
User-agent: Evolution 3.38.3-1

awds--- via Peer-to-Peer networking with GNUnet schreef op wo 02-03-
2022 om 09:31 [-0600]:
> Since GNUnet is currently an academic exercise, it should be removed
> from main distribution repositories. For example: Anyone thinking to
> try GNUnet on Debian-based machines would look in Synaptic and install
> GNUnet v0.10.1. Presumably that build-version worked when it was first
> included in the repositories, but now GNUnet is at v0.16.0 which is not
> backward compatible.

Instead of removing the package because of it being an old version,
wouldn't it be better to update it?  In Guix, GNUnet is at the somewhat
old v0.13.0, but that's only because of the test failures with v0.15. 
Now almost all tests pass and it seems like it will soon be updated in
Guix (

I don't see the implication ‘academic exercise’ -> ‘remove it’ here.
It's possible to experiment with GNUnet, e.g. I've been writing a
partial (Guile) Scheme port of the client libraries and I'm planning
on integrating it with Guix (for P2P substitutes and source code
downloading).  To test this Scheme library, I use the GNUnet services.

If the distro did not include GNUnet, then writing these libraries
(and eventually integrating it in Guix) would be a lot harder ...

And by trying things out, you can find problems and fix them, slowly
making GNUnet more suitable for the general public (e.g. I found some
small issues with the DHT and NSE services that were uncovered and
fixed by the Scheme port, once identified they were easy to fix).

Also, last time I tried, GNUnet is not merely an academic exercise, I
successfully searched for files and downloaded them (using the
graphical client for file-sharing).  I had some trouble with the
configuration though (I don't recall the details, something about not
being able to contact to peers maybe, maybe NAT punching not working?
I probably should have contacted back then ...).


Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]