help-gnuastro
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [help-gnuastro] GNU Astro configure error - missing WCSLIB component


From: Duane Booher
Subject: Re: [help-gnuastro] GNU Astro configure error - missing WCSLIB component
Date: Fri, 25 May 2018 17:16:28 +0000

Okay, I got past the ./configure problem and then the 'make -j8' got these 
errors:

make[2]: *** [arithmetic-bitrsh.lo] Error 1
In file included from ./gnuastro/blank.h:28:0,
                 from arithmetic-bitor.c:30:
./gnuastro/data.h:29:24: fatal error: wcslib/wcs.h: No such file or directory
 #include <wcslib/wcs.h>

So I tried both of these:
./configure --prefix=/packages/gnuastro/0.5 LDFLAGS=-L/packages/wcslib/5.18/lib 
--includedir=/packages/wcslib/5.18/include/wcslib
./configure --prefix=/packages/gnuastro/0.5 LDFLAGS=-L/packages/wcslib/5.18/lib 
--includedir=/packages/wcslib/5.18/include

However I am still getting the same 'make -j8' errors. I must be missing 
something on the configure line.

Duane

´╗┐On 5/25/18, 10:00 AM, "Mohammad Akhlaghi" <address@hidden> wrote:

    Thanks a lot for the prompt reply.
    
    Indeed, the `config.log' file shows that my guess of confusing the two 
    `libwcs's was not the cause.
    
    But I did notice a typo in my last mail that is also present in the 
    first `config.log' file you sent (which contained the `LDFLAGS' option).
    
    I had forgot to write the `-L' before the directory. The "C compiler 
    cannot create executables" configuration error was because of missing 
    this `-L'.
    
    Could you also try the following command:
    
    ./configure --prefix=/packages/gnuastro/0.5 
    LDFLAGS=-L/packages/wcslib/5.18/lib
    


reply via email to

[Prev in Thread] Current Thread [Next in Thread]