help-gnu-utils
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: imake,gmake on hp-ux


From: Yuri Shtil
Subject: Re: imake,gmake on hp-ux
Date: Sat, 08 May 2004 01:15:31 GMT

I did some investigation and discovered that the cpp on hp does not define
the symbol hpux even though the man page claims it should.
Imake looks for this symbol when processing the config files. I solved the
problem by specifying -Dhpux when building and invoking imake on HP. It is
kind of odd, since imake is supposed to figure out the platform  instead of
being told.

However imake still does not process gmake ifdef/endif's when they are
inside actions. I have solved this by filtering imake output file.

Oh well, one has to learn all the time !!! -:)

"Chuck Slivkoff" <address@hidden> wrote in message
news:address@hidden
> On Fri, 07 May 2004 01:59:18 +0000, Yuri Shtil wrote:
>
> > Hi all,
> > I may be shooting in the dark ...
> >
> > I am trying to use imake to generate gnu make files on multiple
platforms.
> >
> > I pulled X11R6-7.0 code for imake. It is pretty recent. ANyway, the
imake I
> > built works perfectly on solaris.
> > The same imake compiled on hp-ux seems to not work properly. The reason
is
> > that the cpp that imake heavily relies upon sticks an extra space at the
> > beginning
>
> Are you defining FIXUP_CPP_WHITESPACE in imakemdep.h?
>
> You might also try:
>
> #define DEFAULT_CPP "/opt/langtools/lbin/cpp"
>
> (or whatever cpp works better for you.)
>
>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]