[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with align-regexp with GNU/Emacs 29+

From: Lele Gaifax
Subject: Re: Problem with align-regexp with GNU/Emacs 29+
Date: Fri, 10 Mar 2023 08:32:00 +0100
User-agent: Gnus/5.13 (Gnus v5.13)

Michael Heerdegen <> writes:

> Lele Gaifax <> writes:
>> [...]
>> Using `C-x h C-U M-x align-regexp RET ,\(\s-*\) RET RET RET y' didn't
>> change  the buffer at all.
>> [...]
>> Am I doing something wrong?
> I don't know.  Your example works as expected for me in Emacs master
> compiled an hour ago.

That's really surprising, as five different compilations (two under
NixOS, both packaged upstream, and three under Debian sid (emacs-28 from
Debian's repo, 29 and 30 compiled by me)) that give the same result
is... puzzling!

But your positive check suggest that the problem is on my side, in some
way: I will try to update my Emacses and report back.

> In which kind of buffer did you try that?

I tried several major modes, but that did not alter the result: this
originated in a sql-mode buffer (I needed to align the VALUES of a
multi-row INSERT), then I tried in a text-mode, and used the latter to
test the much simpler snippet I used in my original mail. Right now I
tried also in fundamental-mode, and the text does not align.

Thanks&bye, lele.
nickname: Lele Gaifax | Quando vivrò di quello che ho pensato ieri
real: Emanuele Gaifas | comincerò ad aver paura di chi mi copia.  |                 -- Fortunato Depero, 1929.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]