help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp hang waiting for prompts from remote shell


From: Michael Albinus
Subject: Re: Tramp hang waiting for prompts from remote shell
Date: Fri, 08 Nov 2019 09:58:11 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Zhongwei Yao <address@hidden> writes:

> Hi, all,

Hi Zhongwei,

> when I open /ssh:ser03: in emacs, it hangs with prompt: Waiting for prompts
> from remote shell...
>
> My setup is 1. start emacs by emacs -Q, 2. remove server ser03's .bashrc
> and .bash_profile is cleared. and emacs is version 26.2, tramp version is
> 2.3.5.26.2.
>
> I set the tramp-verbose to 10 and get the following log:
>
> 15:44:14.206923 tramp-set-connection-property (7) # process-buffer nil
> 15:44:14.207182 tramp-maybe-open-connection (3) # Opening connection for
> ser03 using ssh...
> 15:44:14.207512 tramp-get-connection-property (7) # login-args undef
> 15:44:14.207592 tramp-get-connection-property (7) # login-args undef
> 15:44:14.207683 tramp-get-connection-property (7) # process-name nil
> 15:44:14.207745 tramp-get-connection-property (7) # process-buffer nil
> 15:44:14.208550 tramp-set-connection-property (7) # vector (tramp-file-name
> ssh nil nil ser03 nil /mnt/ssd/user01/ nil)
> 15:44:14.208636 tramp-maybe-open-connection (6) # /bin/sh -i
> 15:44:14.208698 tramp-get-connection-property (7) # vector (tramp-file-name
> ssh nil nil ser03 nil /mnt/ssd/user01/ nil)
> 15:44:14.208769 tramp-get-connection-property (7) # check-remote-echo nil
> 15:44:14.208825 tramp-get-connection-property (7) # check-remote-echo nil
> 15:44:14.209513 tramp-accept-process-output (10) # *tramp/ssh ser03* run t
> #$
> 15:44:14.209580 tramp-get-connection-property (7) # check-remote-echo nil
> 15:44:14.209637 tramp-get-connection-property (7) # check-remote-echo nil
> 15:44:14.209702 tramp-wait-for-regexp (6) #
> #$
> 15:44:14.209770 tramp-get-connection-property (7) # login-program undef
> 15:44:14.209838 tramp-get-connection-property (7) # login-args undef
> 15:44:14.209903 tramp-get-connection-property (7) # login-env undef
> 15:44:14.209968 tramp-get-connection-property (7) # async-args undef
> 15:44:14.210030 tramp-get-connection-property (7) # connection-timeout undef
> 15:44:14.210090 tramp-get-connection-property (7) # temp-file undef
> 15:44:14.210201 tramp-set-connection-property (7) # temp-file
> /tmp/tramp.Retqm2
> 15:44:14.210691 tramp-maybe-open-connection (3) # Sending command ‘exec ssh
>   -o ControlMaster=auto -o ControlPath='tramp.%C' -o ControlPersist=no -e
> none ser03’
> 15:44:14.210773 tramp-get-connection-property (7) # process-name nil
> 15:44:14.210838 tramp-get-connection-property (7) # remote-echo nil
> 15:44:14.210896 tramp-send-command (6) # exec ssh   -o ControlMaster=auto
> -o ControlPath='tramp.%C' -o ControlPersist=no -e none ser03
> 15:44:14.210958 tramp-get-connection-property (7) # process-name nil
> 15:44:14.211018 tramp-get-connection-property (7) # chunksize nil
> 15:44:14.211077 tramp-set-connection-property (7) # last-cmd-time (24005
> 7374 211060 426000)
> 15:44:14.211139 tramp-send-string (10) # exec ssh   -o ControlMaster=auto
> -o ControlPath='tramp.%C' -o ControlPersist=no -e none ser03
> 15:44:14.211199 tramp-get-connection-property (7) # process-buffer nil
> 15:44:14.211281 tramp-set-connection-property (7) # first-password-request
> nil
> 15:44:14.211480 tramp-process-actions (3) # Waiting for prompts from remote
> shell...
> 15:44:15.212739 tramp-accept-process-output (10) # *tramp/ssh ser03* run nil
> 15:44:15.212812 tramp-process-one-action (5) # Looking for regexp
> "\(.*\(user\|login\)\( .*\)?: *\)\'" from remote shell
> 15:44:15.212878 tramp-get-connection-property (7) # check-remote-echo nil
> 15:44:15.212935 tramp-get-connection-property (7) # check-remote-echo nil
>
> I notice the remote shell doesn't have any output at the following line:
> 15:44:15.212739 tramp-accept-process-output (10) # *tramp/ssh ser03* run nil

Right. But there's just one second between sending the ssh command, and
this output line. Could you pls wait for some more seconds?

> But when I try to run the command:
>   exec ssh   -o ControlMaster=auto -o ControlPath='tramp.%C' -o
> ControlPersist=no -e none ser03
> it give the following output:
>   Welcome to Ubuntu 16.04.6 LTS (GNU/Linux 4.15.0-47-generic x86_64)
>
>  * Documentation:  https://help.ubuntu.com
>  * Management:     https://landscape.canonical.com
>  * Support:        https://ubuntu.com/advantage
>
> 0 packages can be updated.
> 0 updates are security updates.
>
> New release '18.04.3 LTS' available.
> Run 'do-release-upgrade' to upgrade to it.
>
>
> Last login: Fri Nov  8 15:42:10 2019 from 192.168.1.1

Hmm, it doesn't show any prompt. Is it just a copy/paste error, or is
that the whole output running the command?

> What can I do to solve it?

Pls show *everything* you've got. And pls make these output listings and
Tramp debug buffers attachments of your email, in order to prevent any
mail program to chime in. Every character counts!

> Best regards,
> Zhongwei

Best regards, Michael.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]