help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot update packages (keyring issue)


From: Robert Pluim
Subject: Re: Cannot update packages (keyring issue)
Date: Thu, 03 Oct 2019 19:37:48 +0200

>>>>> On Thu, 3 Oct 2019 09:10:33 -0700, Joe Riel <address@hidden> said:

    Joe> I have Emacs 25 and cannot update the package list, or install 
packages,
    Joe> because, apparently, the keyring is out-of-date.  I saw a reference to
    Joe> a new package gnu-elpa-keyring-update, that is supposed to solve the
    Joe> problem, but, naturally, package-install won't work because of the 
    Joe> above issue.  

    Joe> What's the best way to fix this?

You can temporarily set package-check-signature to nil, install the
keyring update, then set it back. The description of the
gnu-elpa-keyring-update package lists a couple of other options.

    Joe> Will the package work with Emacs 25?

Probably, but Iʼve never tested it :-)

Robert



reply via email to

[Prev in Thread] Current Thread [Next in Thread]