help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to clipboard copy emacs help text by user-made interactive funct


From: Bruno Barbier
Subject: Re: How to clipboard copy emacs help text by user-made interactive function kill-ring-save
Date: Fri, 10 May 2019 01:34:53 +0200

Hi,

Budi <address@hidden> writes:

> I tried to clipboard copy some emacs read-only text by user-made
> interactive function kill-ring-save, but fail
> It's not M-w bound to kill-ring-save emacs built in function which is working
>
> but as my preceding question, the copy :
>
> (defun copy (b e)
>   (interactive "r")
>   (if (use-region-p) (call-interactively 'kill-ring-save)
>   (save-excursion
>   (beginning-of-line)
>   (set-mark (line-end-position))
>   (kill-ring-save (point)(mark))
>   ))))

(When you define your own function, you should use your own prefix
to avoid replacing Emacs own functions.

    copy => my-copy, budi-copy, etc.
)

Assuming you're getting the following error:

   The mark is not set now, so there is no region

Your line:

   (interactive "r")
   
tells Emacs to provide a region "r" (point=>b and mark=>e) when called
interactively; it fails when there is no mark.

Remove the arguments 'b', 'e', don't request a region (drop the "r"),
and it should work.

If it doesn't, try to copy/paste the exact error and the exact steps to
reproduce.

It's probably better to use the same thread until your problem is
solved by the way, specially if you mentioned your previous emails.


Regards,

Bruno









> (global-set-key (kbd "C-c") 'copy)
>
> cannot copy such case above,
> any idea what's actually made different behavior of kill-ring-save ?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]