help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Source file '.../killer-source.el' newer than byte-compiled file


From: Eli Zaretskii
Subject: Re: Source file '.../killer-source.el' newer than byte-compiled file
Date: Tue, 23 Apr 2019 22:02:36 +0300

> From: Emanuel Berg <address@hidden>
> Date: Tue, 23 Apr 2019 20:32:45 +0200
> 
> Eli Zaretskii wrote:
> 
> > Its purpose is to tell you that Emacs loads
> > a .elc file that is older than the
> > corresponding .el file.
> > See load-prefer-newer.
> 
> OK, so I should have that `t'!

If you really want that.  Personally, I'm not sure.

> Is there a downside to this, assuming the
> latest version is always the better, and b.elc
> *is* compiled eventually?

That assumption might be false.  For example, you may be working on
a.el, and it might have bugs.

> If there is a downside, i.e. it _is_ better to
> load the byte-compiled code (assuming it to be
> newer than the source), what should one do?

Just ignore those messages, really.  They are mostly harmless.  You
could compile the dependent file again if you want, but that is rarely
needed, mainly when they define macros that were changed, and those
macros are used by the files which require a.el.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]