help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ubuntu 16.04 server --- Contacting host: elpa.gnu.org:80 when packag


From: izzy . yichao . cai
Subject: Re: Ubuntu 16.04 server --- Contacting host: elpa.gnu.org:80 when package-refresh-contents
Date: Thu, 18 Jan 2018 18:28:29 -0800 (PST)
User-agent: G2/1.0

address@hidden 2018年1月17日星期三 UTC+8下午8時12分42秒寫道:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On Wed, Jan 17, 2018 at 03:56:34AM -0800, address@hidden wrote:
> > Hi folks,
> > 
> > I have tried to install elpy in emacs (24.5.1) on my server which is 
> > running Ubuntu 16.04.
> > 
> > When I run M-x package-refresh-contents, emacs successfully connected to 
> > stable.melpa.org:443. 
> > After that, it was hanged on "Contacting host: elpa.gnu.org:80". I am 
> > pretty sure that I am not behind proxy. 
> 
> I don't know about this...
> 
> > Then I tried to ping this host and this is what I got:
> > address@hidden:~$ ping elpa.gnu.org:80
> > ping: unknown host elpa.gnu.org:80
> 
> ...but this won't work. Indeed, "elpa.gnu.org:80" isn't a host name.
> Try pinging "elpa.gnu.org". It's there and replies to pings :)
> 
> > However, pinging other websites is normal. I also tried to access this 
> > (elpa.gnu.org:80) on my local computer and it is accessible.
> 
> You don't ping websites -- you ping hosts. Actually, elpa.gnu.org
> is serving a website at port 80 currently. So the URL
> http://elpa.gnu.org:80/ should get you something (since port 80
> is the default for http anyway, you can leave it out).
> 
> That said, elpa.gnu.org is also serving https, so I'd strongly
> recommend going with https://elpa.gnu.org/
> 
> Cheers
> - -- tomás
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.12 (GNU/Linux)
> 
> iEYEARECAAYFAlpfPa0ACgkQBcgs9XrR2kZ+5wCfUj5LUoKJbu+ty2kjd6fJCKjK
> d0gAnis0HbxOkzP0n579SeUupTJUFEAa
> =136e
> -----END PGP SIGNATURE-----

Hi Tomas,

Basically, I've been following the instruction from elpy github repo for 
installation. (https://github.com/jorgenschaefer/elpy)

In my .emacs file. I've added the following:
```
(require 'package)
(add-to-list 'package-archives
             '("melpa-stable" . "https://stable.melpa.org/packages/";))

(package-initialize)
(elpy-enable)
```

So, I am using https, which is a safe practice as Dan pointed out.
How did emacs decide to connect to elpa.gnu.org? Is this a default of emacs? 
Because I never included the elpa.gnu.org link in my .emacs file or evaluated 
it in my buffer. (That means I have no choice in using https or http. :( It 
just happened and I don't know why.)

> ...but this won't work. Indeed, "elpa.gnu.org:80" isn't a host name.
> Try pinging "elpa.gnu.org". It's there and replies to pings :)
Yep, I tried to ping "elpa.gnu.org" and it did replied.

------------------
**ISSUE UPDATE**:
------------------
This is an update on the issue.

So, I have successfully installed eply in my emacs right now! However, this 
remains mysterious to me as in how it worked out.

In my first post, emacs was hanged on "Contacting host: elpa.gnu.org:80". 
Exiting emacs here and running package-install resulted in could not find the 
elpy package. 
Since I am running emacs on my server, I decided to let it run in hope that it 
would get connected anyhow. 
After two days, when I come back to it, it's still hanged. So I quite emacs 
(C-x C-c) and restart it. Then, I run package-install and elpy now can be 
installed.

Then, I tried package-refresh-content again but it still got hanged.

Do you have any idea how this might happen?
Thank you so much!

Best regards,
Yichao



reply via email to

[Prev in Thread] Current Thread [Next in Thread]