help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build failure caused by a .tit file


From: Göktuğ Kayaalp
Subject: Re: Build failure caused by a .tit file
Date: Mon, 17 Apr 2017 18:55:30 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

On 2017-04-17 17:45 +0300, Eli Zaretskii <address@hidden> wrote:
> This is not a good place to report failures to build Emacs.

I'm sorry.  Should I rather post it to emacs-devel or report bug?

> This error message comes from this snippet in titdic-cnv.el:
>
>         ;; Decode the buffer contents from the encoding specified by a
>         ;; value of the key "ENCODE:".
>         (if (not (search-forward "\nBEGIN" nil t))
>             (error "TIT dictionary doesn't have body part"))
>
> Is it really true that CCDOSPY.tit you have has no line that begins
> with "BEGIN"?  Otherwise, why doesn't the search-forward call succeed?

The line 55-57 reads

# the following line must not be removed
BEGINDICTIONARY
#

and manually running

M-: (search-forward "\nBEGIN" nil t)

returns 1850.  The snippet you've included when run via M-:, works as
expected, i.e., no errors, moves to line 56, after first ‘N’.

> Did you try "make distclean" before building?

Yes, I tried starting from scratch both via the build tool and fetching
a clean copy of the repository.  FWIW the file's coding is ‘euc-china’
and it has 565 lines (another reply was asking whether the file was a
big one).



reply via email to

[Prev in Thread] Current Thread [Next in Thread]