[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: frame-cmds enlarge-font

From: Drew Adams
Subject: RE: frame-cmds enlarge-font
Date: Fri, 16 Dec 2016 06:56:26 -0800 (PST)

> I want the functionality of zoom-frm or default-text-scale (zooming in
> on all windows of a frame).
> I installed both via elpa, but none worked. The first zoom worked,
> then nothing more.

Sorry for your trouble.

> A little investigation hints that the problem is with frame-cmds.el,
> and its function enlarge-font.  This seems to relate to an ancient
> but (#119 and #1562), Emacs 23. I am currently on Emacs 24.4.1
> because Debian.

I doubt that that bug is relevant here.  As that comment says, it was
fixed in Emacs long ago, so the workaround commented out is not needed
or useful.

> There is a comment in frame-cmds.el, with a work-around for this bug.
> I tested it to no av, but I'm not sure I did it right:
> - replaced frame-cmds.el function enlarge-font with the work-around.
> Recompile with (byte-recompile-directory package-user-dir nil 'force),
> start a new emacs instance. This seems to work better when I call
> enlarge-font directly, although 1 and -1 as parameters don't always
> work. zoom-frm's command zoom-in still works only once.

See above.

> For now I will just define my-enlarge-font in my init.el as what is in
> the comment in frame-cmds.el, and call that directly. It would have
> been nice to have the extra functionality of zoom-frm, but I'm not
> sure what the correct way to do that: modify frame-cmds, recompile,
> make zoom-frm use that.

I suggest you follow up with me off list.  It's not at all clear
what you are doing or what does not work.  FWIW, I use `enlarge-font'
and the commands in `zoom-frm.el' all day long everyday, in every
Emacs version since 20, with no problem.

A guess is that you are doing something else in your init file, which
is causing problems (especially since you seem to have the same
problem with both my code and `default-text-scale').

Do you see the same problem if you start Emacs using `emacs -Q' (no
init file), and you then load only `frame-cmds.el' and `zoom-frm.el'?
If so, then that's the place to start the discussion, to find the

If not, then recursively bisect your init file, to find the cause.
You can use command `comment-region' to comment out a block of text
(with `C-u' it uncomments).  Remove 1/2, then 3/4, 7/8,... of your
init file until you find the problem.

Follow up off list, please; this is not the place to debug the
problem.  You can always report back to the list about anything
you discover, if you think it can help others.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]