help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w3m SSL handling error


From: B.V. Raghav
Subject: Re: w3m SSL handling error
Date: Tue, 18 Oct 2016 11:51:39 +0530
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

Bob Proulx <address@hidden> writes:

> [snip]

> I think your system may be in an unhappy state.  This is probably a
> topic for debian-user but...  Unless someone complains let's just keep
> going here.
>
> You later say you are running behind a network wide proxy which I
> think is likely the problem.  But first let's start with your system
> anyway.  I tend to inspect these things from several different
> viewpoints all at once and then something wrong appears that can be
> fixed.  Please inspect with (on my Debian Sid system for example).
> Following are a few commands and example output shown from my system.
> Then later down I will ask about the network proxy.
>
> [snip]
>
> In the above I see that w3m is linking against libssl.so.1.0.2 =>
> /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2 which is in the libssl1.0.2
> package.
>
> [snip]
>
> That is from Debian Sid today and fully updated.  I am hoing that your
> system will show different version numbers.  I am in the US and using
> the US mirror but I expect your mirror will be different which is
> okay.  The versions of the packages should be the same however.

The results are matching!

$ apt-cache policy w3m
w3m:
  Installed: 0.5.3-29
  Candidate: 0.5.3-29
  Version table:
 *** 0.5.3-29 500
        500 http://mirror.cse.iitk.ac.in/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status

except the w3m version 0.5.3-29 in my case vs 0.5.3-31 in your case. My
mirror does not have it updated as yet, I checked. But I think that's
okay.

$ apt-cache policy libssl1.0.2
libssl1.0.2:
  Installed: 1.0.2h-1
  Candidate: 1.0.2j-1
  Version table:
     1.0.2j-1 500
        500 http://mirror.cse.iitk.ac.in/debian stretch/main amd64 Packages
 *** 1.0.2h-1 100
        100 /var/lib/dpkg/status

$ dpkg -S /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2
libssl1.0.2:amd64: /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2

$ ldd -d -r /usr/bin/w3m
        linux-vdso.so.1 (0x00007fff49974000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fe639383000)
        libgc.so.1 => /usr/lib/x86_64-linux-gnu/libgc.so.1 (0x00007fe639113000)
        libssl.so.1.0.2 => /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2 
(0x00007fe638ea9000)
        libcrypto.so.1.0.2 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2 
(0x00007fe638a46000)
        libgpm.so.2 => /usr/lib/x86_64-linux-gnu/libgpm.so.2 
(0x00007fe638840000)
        libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 
(0x00007fe638615000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fe638274000)
        /lib64/ld-linux-x86-64.so.2 (0x0000563c1eb9f000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 
(0x00007fe638057000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fe637e52000)

> Can you bypass your proxy and connect directly in order to test your
> software configuration?

Yes. I did that:

$ http_proxy= w3m https://www.emacswiki.org/

But result is the same
SSL error: error:0906D06C:PEM routines:PEM_read_bio:no start line

Thanks for your support

r
-- 
Raghav

यस्य स्मरण मात्रेन जन्म संसार बन्धनात् विमुच्यते नमस्तस्मै विष्णवे प्रभविष्णवे
Salutations to the one, whose mere thought itself manifests in freedom
from bonds of the world of life.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]