help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: help debugging a segfault


From: Eli Zaretskii
Subject: Re: help debugging a segfault
Date: Tue, 18 Oct 2016 08:45:19 +0300

> Date: Mon, 17 Oct 2016 13:16:33 -0700 (PDT)
> From: Sam Halliday <address@hidden>
> 
> Despite being very stable since I installed it when released, Emacs 25.1 has 
> started to segfault on me this week in a hard-to-reproduce manner.
> 
> I use ArchLinux and I recompiled with debugging symbols to obtain a detailed 
> core dump / crash log.
> 
> But this is all I got when running with gdb until it crashed:
> 
> =============================
> Thread 1 "emacs" received signal SIGSEGV, Segmentation fault.
> re_search_2 (address@hidden <searchbufs+2912>, address@hidden <error: Cannot 
> access memory at address 0x597b790>, address@hidden, 
>     address@hidden <error: Cannot access memory at address 0x597b790>, 
> size2=65565, startpos=646, address@hidden, range=509, 
>     regs=0xc2c8d0 <search_regs>, stop=1155) at regex.c:4464
> 4464                int len = BYTES_BY_CHAR_HEAD (*p);
> =============================

Sounds like another case of bug#24358, see

  https://debbugs.gnu.org/cgi/bugreport.cgi?bug=24358#41

and the following discussion.  Your OS is also the same as reported
there, which increases the probability of this being the same issue.

If you ever succeed in getting meaningful data about the crash, or
some way of reproducing it, please post to address@hidden



reply via email to

[Prev in Thread] Current Thread [Next in Thread]