help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with auctex


From: Tassilo Horn
Subject: Re: Problem with auctex
Date: Sun, 16 Oct 2016 19:09:44 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

me <address@hidden> writes:

Hi!

> I've recently updated my emacs to the version 26.0.50.2 (package
> emacs- snapshoot for Ubuntu) and since a couple of days, auctex is not
> automatically loaded anymore when I edit LaTeX file (*.tex). Auctex
> was installed from elpa (or melpa I do not remember) and is stored
> into $HOME/.emacs.d/elpa/auctex-11.89.5/.

I myself am using Emacs 26 (from the git master branch), and for me
AUCTeX installed from ELPA works just fine and loads after finding the
first TeX file.  I've tested it just yesterday.

What does C-h f tex-mode RET show you?  Here it shows

,----[ C-h f tex-mode RET ]
| tex-mode is an interactive autoloaded compiled Lisp function in ‘tex-mode.el’.
| 
| (tex-mode)
| 
| Parent mode: ‘text-mode’.
| 
| :override advice: ‘TeX-tex-mode’
| 
| Major mode for editing files of input for TeX, LaTeX, or SliTeX.
| Tries to determine (by looking at the beginning of the file) whether
| this file is for plain TeX, LaTeX, or SliTeX and calls ‘plain-tex-mode’,
| ‘latex-mode’, or ‘slitex-mode’, respectively.  If it cannot be determined,
| such as if there are no commands in the file, the value of ‘tex-default-mode’
| says which mode to use.
`----

Note the :override advice: line which indicates that AUCTeX has been
loaded.

> If, within emacs, I type M-x load-library <ret> auctex.el and then M-x
> latex-mode, everything is then ok.. Auctex is not required explicitly
> into my .emacs file (as specified into the documentation).

That should not be needed.  Do you have any configs wrt. AUCTeX?  If so,
could you show them?

Bye,
Tassilo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]