help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: resending... desktop files not working for recent ubuntu?


From: Rustom Mody
Subject: Re: resending... desktop files not working for recent ubuntu?
Date: Wed, 1 Jun 2016 21:19:21 +0530

On Tue, May 31, 2016 at 10:51 AM, Alexis <address@hidden> wrote:

>
> Rustom Mody <address@hidden> writes:
>
> Apologies for second copy 1st doesnt seem to have appeared
>>
>> --------------------------------------------- I have this emacs.desktop
>> file put in ~/.local/share/applications
>>
>> --------------- [Desktop Entry] Name=EmacsClient GenericName=Text Editor
>> Comment=Edit text
>> MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
>>
>> Exec=emacsclient -n -a emacs %F Icon=python Type=Application
>> Terminal=false Categories=Development;TextEditor; StartupWMClass=Emacs
>>
>> --------------- Currently this laptop is on ubuntu 16.4 (xenial) --
>> vanilla unity desktop It used to work ok in earlier ubuntus Now on 16.4 it
>> shows 2 emacs icons when editing a file via emacsclient Clicking the second
>> icon shows no effect After about 10 seconds it disappears
>>
>> Dont know when it stopped working because frankly I am not much of a
>> nautilus -> click -> emacsclient type of user
>>
>> Current generation -- my students -- however default to this kind of
>> usage And so they default to one or both of - gedit by default - dozens of
>> emacses open for each file they clicked
>>
>
> Shouldn't you specify '' (i.e. the empty string) as the -a argument in the
> Exec option? From the man page for emacsclient(1):
>
>    -a, --alternate-editor=EDITOR
>    if the Emacs server is not running, run the specified editor
> instead.  This can also be specified via the    `ALTERNATE_EDITOR'
> environment variable.  If the value of    EDITOR is the empty string, run
> `emacs --daemon' to start    Emacs in daemon mode, and try to connect to it.
>
>
Tried changing it...  Same behavior

It would be nice if people with other ubuntu versions and other linux
desktops could try it and inform.

If it works then its a bug specific to this ubuntu
If not its a more general emacs bug


reply via email to

[Prev in Thread] Current Thread [Next in Thread]