help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Configuring Anaconda-Mode and Company-Mode with IPython


From: Dmitry Gutov
Subject: Re: Configuring Anaconda-Mode and Company-Mode with IPython
Date: Fri, 17 Apr 2015 04:36:47 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Thunderbird/36.0

Hi!

On 04/15/2015 04:42 PM, address@hidden wrote:
I am new to using Emacs, and am currently trying to configure it to be a more 
robust environment for coding in Python.

To do this I'm using Company-Mode with Anaconda-Mode for autocompletion, along 
with the defaul Python.el mode

I would like to use IPython as my repl, but I'm experiencing some odd behavior 
with autocompletion in the IPython buffer (autocompletion works fine in the 
normal python buffer(s)).

Sorry, I don't do Python, and I'm a bit too busy to try you config. Here's what you should try:

First, disable anaconda-mode and see how much of the described behavior you can reproduce. If there are problems you can now attribute to anaconda-mode, file issues on its bug tracker.

The rest of those should be problems or limitations of the built-in Emacs completion (which uses the REPL buffer), which you can file bugs for, with `M-x report-emacs-bug'.

But to double-check, disable `company-mode', and try pressing C-M-i: you should see the same results in the *Completions* buffer.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]