help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Adding Package Repositories in Gnu Emacs 24.4


From: Bourgoin, Mario
Subject: RE: Adding Package Repositories in Gnu Emacs 24.4
Date: Wed, 15 Apr 2015 22:42:30 +0000

Thank you for replying.

> If it doesn't "just work", please report it as a bug.

It does work, for which I'm glad. So I recommended it on melpa.org as an 
alternative to that they said to do, because their approach led to me having 
AUCTeX problems. But one of the melpa collaborators said that no, that doesn't 
work for all Emacs bundles.

> None of those calls pays attention to package-archives, so if there's a 
> problem it must be elsewhere.

My AUCTeX problem had nothing to do with package-archives, except as a solution 
to my problem. Callingl package-initialize in my .emacs was very much the way I 
saw the problem. (I deleted all local initializations, re-installed Vincent 
Goulet's Emacs bundle, Tassilo Horn, an admin on the AUCTeX project, wrote to 
me on bug-auctex that "Indeed, the auctex initializer of the elpa package uses 
some hack which I actually don't understand."

--
Mario Bourgoin
Senior Data Scientist - Hopkinton
EMC CTD Symmetrix uCode
(508) 249-1297 Direct


-----Original Message-----
From: address@hidden [mailto:address@hidden On Behalf Of Stefan Monnier
Sent: Tuesday, April 14, 2015 9:01 PM
To: address@hidden
Subject: Re: Adding Package Repositories in Gnu Emacs 24.4

> How can the custom system be reliably used to add package repositories 
> to Gnu Emacs 24.4 (and later)?

If it doesn't "just work", please report it as a bug.
There are indeed problems when using Custom for some of package.el's 
customization variables, but for `package-archives' I am not aware of any 
special problems.

> (package-initialize)
[...]
> (require 'some-package)
> (some-package-whatever-mode t)

None of those calls pays attention to package-archives, so if there's a problem 
it must be elsewhere.

> My problem with this was that running "package-initialize" in my Emacs 
> initialization file resulted in a recently-installed version of AUCTeX
> (11.88.4) being shadowed by an older built-in version of AUCTeX on 
> load-path. (I was using Vincent Goulet's installer 
> emacs-24.4-modified-1.exe from 
> http://vgoulet.act.ulaval.ca/en/emacs/windows
> and that problem may be due to AUCTeX initialization.)

This probably had nothing to do with your setting of package-archives.
And without knowing more about how your older installation fo AUCTeX is added 
to load-path, there's not much we can say.


        Stefan





reply via email to

[Prev in Thread] Current Thread [Next in Thread]