help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "lein repl" malfunctions in Emacs (24.3.1) subprocess?


From: cohagan
Subject: Re: "lein repl" malfunctions in Emacs (24.3.1) subprocess?
Date: Mon, 13 Apr 2015 14:47:40 -0700 (PDT)
User-agent: G2/1.0

Well, I of course figured this out (sort of) shortly after posting. I should 
have been using cider-jack-in rather than "lein repl" to get a Clojure REPL 
going in a buffer. So, my immediate problem is solved; however I'm still 
curious as to why the lein repl won't work in Emacs?

Bill

On Monday, April 13, 2015 at 4:23:48 PM UTC-5, address@hidden wrote:
> I'm trying to use Emacs as my dev environment for Clojure programming under 
> Windows 8.1. When I open a subprocess (via M-x shell) I get a command prompt 
> as expected. I can then run "lein test" and my unit tests are run as expected 
> -- with output to the shell buffer as expected.
> 
> If, however, I enter "lein repl" then the REPL starts as expected, but is non 
> responsive. For example, if I enter (+ 1 2) at the user=> prompt (followed by 
> Enter) I get no response at all.  The input isn't echoed (as expected) and no 
> output at all appears.
> 
> Note that "lein repl" runs fine at a normal command prompt (or within a 
> subprocess buffer in Epsilon (an Emacs clone.)) This problem occurs on 3 
> different machines.
> 
> This has worked for me in the past so obviously something has broken, but I 
> haven't a clue what it might be or how to troubleshoot.
> 
> Any pointers/suggestions would be greatly appreciated.
> 
> Thanks in advance,
>  Bill



reply via email to

[Prev in Thread] Current Thread [Next in Thread]